Mail is not being sent

Incident Report for metapulse.com

Resolved

Mail should be working again. Please let us know if you are experiencing any issues receiving email from envisage.
Posted Jun 09, 2020 - 19:53 EDT

Update

We are still working on a solution for this mail outage. Thank you for your patience.
Posted Jun 09, 2020 - 16:40 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 09, 2020 - 12:10 EDT

Investigating

There is an issue with our mail system causing all email to not be sent from envisage. We are currently investigating.
Posted Jun 09, 2020 - 11:26 EDT
This incident affected: Web Site.